Wie verrechne ich Minusstunden und Plusstunden?

5 Antworten

Du hast meiner Kenntnis nach 3 Möglichkeiten, alle drei unschön:

1: zum 1904-Zeitsystem wechseln. Das kann auch mit negativen Zeiten rechnen. ABER: die Wochentage zählen anders und viele Formeln müssen überprüft werden. Ausserdem ist das eine xl-Einstellung, will jemand anderes da reinschauen, müsste er auch erst umstellen, was alle anderen Dateien beeinflusst.

Du kannst das über Formeln und Texte lösen: =Wenn(A1<0;"-"&Text(abs(A1);"[h]:mm";A1)Du kannst dann allerdings nicht über Summe zusammenzählen, sondern nur einzeln

3: Ich bevorzuge eine Lösung über ein Ben,-def. Zellformat, zB sowas:

[Blau][h]:mm;[Rot]-Standard;[magenta]°\:°°;@

da werden positive Zeiten wie üblich dargestellt(1. Abschnitt), 0 als zB °:°° in Magenta (3. Abschnitt) als Anzeige dafür, dass ein spezielles Zellformat vorliegt (Geschmackssache) und negative Zeiten müssen als Industriestunden/24 eingegeben werden oder so:

=-6/24 , was 0,25 Tage ergibt und per Zeitrechnung problemlos mit h:mm -Formaten verrechnet werden kann. Aber bei krummen Stunden kommt man da ins Schleudern, 6,2 h sind 6:12 usw.

Umgehen kann man das so (im obigen Zellformat und Zeiteingabe in die offene Zelle bzw Bearbeitungszeile, also in die Formel direkt):

=-("6:12"*24)

was ich für die beste, weil einzig anschauliche Lösung halte, aber dann muss man kompliziert auswerten, denn den Faktor 24 muss man ja wieder rauskriegen, zB mit:

=+wenn(A1<0;A1/24;A1)

Kannst aber auch generell, auch bei positiven Zeiten

=("6:12"*24) nehmen und hinterher ALLES wieder /24 teilen (Industriestundenrechnung=>h:mm-Systemrechnung)

Du siehst , kein Weg ist einfach, MS stellt sich auf den Standpunkt: negative Zeiten gibt es nicht. Mit etwas Übung kann man aber auch damit leben. Die aber braucht es!

Angesichts des Gesagten ist zu überlegen, ob Du das nicht in zwei Spalten aufteilst, wo in der einen Zelle die positive Zeit, in der anderen etwas steht, was sich über Summewenn differenziert erfassen lässt. Ich denk nochmal nach.

Ich habe schon viele Versuche gesehen, dies mit "Uhrzeiten" zu lösen und spätestens bei "Minusstunden" wird es in Excel übel.
Also mein Rat. Alle Delta Zeiten Dezimal darstellen. Hier lassen sich "minus" Zeiten und "plus" Zeiten wie gewohnt in der Mathematik auf addieren und zum Schluss zur Anschauung auch wieder in die Form hh:mm überführen. Wobei es auch hier knifflig wird sollen mehr als 23:59 Überstunden aufgelaufen sein.

mehr als 23:59 Überstunden: Format [h]:mm zeigt auch 123:45 an, also nur Stunden (s. m. AW)

Neue Antwort:

Da du ja die Anlage der Tabelle anscheinend nicht ändern kannst, ggf so:

Erst mal: 5 April -9:15 und 6 Mai 8:30 sind doch hoffentlich Flüchtigkeitsfehler und müssen 5 April -09:15 bzw 6 Mai 08:30 heissen? und 5 April bzw 6 Mai spielen vermutlich für die Auswertung hier keine Rolle?

Ausserdem: die Summe der positiven Stunden ist nicht 14:15, sondern 38:50, die Differenz also 26:35 (nimm in Zukunft das ZellFormat [h]:mm, das rechnet auch ganze Tage als 24 h

Die Formel zur Auswertung lautet dann (Daten in B59:B63):

=SUMMENPRODUKT(ISTFEHLER(FINDEN("-";$B$59:$B$63;1))*RECHTS($B$59:$B$63;5)) +SUMMENPRODUKT(-NICHT(ISTFEHLER(FINDEN("-";$B$59:$B$63;1)))*RECHTS($B$59:$B$63;5))

Den Datenort schreibe ich jetzt nicht mehr um, die stehen bei Dir sowieso woanders.

Nimmst Du das Zellformat aus der anderen AW:

[Blau][h]:mm;[Rot]-Standard;[Magenta]°\:°°;@

werden Dir wieder Positive Summen im normalen Zeitformat, negative als Tag-Dezimale dargestellt (Rechnen kann xl übrigens fehlerfrei auch mit den als Gartenzaun dargestellten Zeiten, nur nebenbei)

sehe erst jetzt (mal wieder) Deine Klarstellung bzgl der Orte im xl-Sheet. Die Formel lautet:

{=SUMME(WENNFEHLER(C3:D9*1;WECHSELN(C3:D9;"-";"")*-1))}

Das ist eine Matrixformel: {Klammern} nicht miteingeben, sondern die Formel anstatt mit Enter mit Strg+Shift+Enter (am besten rechte Tasten: geht mit einer Hand) abschließen (bei jeder Neubearbeitung wieder!)

Zur Theorie recht gut verständlich (aber schon etwas zeitaufwändig!) guglst Du nach Haserodt, Matrixformeln (ggf noch i'was mit 7 Stationen)

Die Formulierung mit Summenprodukt funkt nicht, sobald Texte als Zwischenergebnis auftauchen, deshalb {Matrixformel}

Frage vorab:

Was genau steht in den Zellen in "C"?

'-03:00 ?

Und willst du als Ergebnis wirklich 14:15 - 12:15 ? Weil du hast ja allein im März schon 21:40 Plusstunden ^^

Lg Tobi

Vielen Lieben Dank für eure schnellen Antworten.

Leider verschiebt sich meine Ecxel Liste hier ein bisschen.

Hier ein Screenshot wies tatsächlich aussieht

Ich würde gerne in Zelle F10 die Verrechneten Stunden haben

 - (Excel, plus und minusstd.verrechnen)

Aber wieso hast du denn bei den Überstunden 14:50?

Steh ich gerade auf dem Schlauch?

8:40 + 21:40 + 08:30 sollten doch eigentlich 38:50h sein oder nicht? Willst du als Ergebnis wirklich 14:50?

@lasttobi12

14:50 zeigt es mir bei folgender Formel an: =SUMME(C3:C8)

-12:15:00 zeigt es mir bei dieser Formel an: =SUMMEWENN(D1:D9;"<0")

Bisher hab ich noch nicht rausgefunden wie ich in Zelle C10 das ganze in HH:MM:SS umstellen kann

@Franziska1612

Zelle C10 habe ich gerade in HH:MM:SS umgewandelt

@lasttobi12

xl unterschlägt in diesem Format die Stunden >=24

s. m. "neue Antwort"

@Iamiam

Das ist mir bewusst. Die Frage war ja, ob sie das so möchte ^^ Weil mir das unsinnig erschien.

Guten Morgen,

es funktioniert jetzt alles so wie ich es haben wollte!!

Vielen lieben Dank für eure Unterstützung und die schnellen Antworten.

Was möchtest Du wissen?